
   
Bern University of Applied Sciences 
Engineering and Information Technology 
 
Division of Electrical and Communication Technology 

02.2013  F. Dellsperger 1 

 

 
 
 
 

AgilentEESof Advanced Design System 
ADS 2012 

 

 
 
 
 

 
 

Student Quick Reference Guide 
 
 
 
 
 

Part 1 



 

  2 

 

 

 

Part 1 

Inhalt 
1. Einleitung und Einstiegshilfen für ADS 2012 ........................................................................................... 3 
2. The ABC of ADS ...................................................................................................................................... 4 

2.1. Main Window ................................................................................................................................... 4 
2.1.1. Opening an existing workspace: ............................................................................................. 5 
2.1.2. Creating a new workspace: ..................................................................................................... 5 
2.1.3. Copying a workspace: ............................................................................................................. 8 
2.1.4. Covert a project from ADS 2009 or older to a workspace: ...................................................... 8 

2.2. Step A: Draw Schematic .................................................................................................................. 9 
2.2.1. Component Parameters ........................................................................................................ 12 
2.2.2. Vendor Component Libraries................................................................................................. 12 

2.3. Step B: Setting Up and Launching a Simulation ........................................................................... 14 
2.4. Step C: Display Simulated Data .................................................................................................... 19 

3. ADS 2012 Design Environment ............................................................................................................. 22 
4. Simulations in ADS ................................................................................................................................ 26 
5. Working with Symbols in ADS2012 ........................................................................................................ 27 

5.1. Create New Workspace ................................................................................................................. 28 
5.2. Create New Library ........................................................................................................................ 28 
5.3. Create New Schematic .................................................................................................................. 28 
5.4. Create New Symbol ....................................................................................................................... 29 
5.5. Setting Design Parameter ............................................................................................................. 31 
5.6. Using Symbol in Other Schematics ............................................................................................... 31 
5.7. Now everything is ready for simulation. ......................................................................................... 35 

6. ADS   Optimization Cockpit .................................................................................................................... 36 
6.1. Setup for Optimization ................................................................................................................... 37 

7. Default Keyboard Shortcuts (hotkeys) ................................................................................................... 50 
8. Built-in Constants, System Units and Prefixes ....................................................................................... 51 

8.1. Built-in Constants .......................................................................................................................... 51 
8.2. System Units ................................................................................................................................. 51 
8.3. System Prefixes ............................................................................................................................. 51 

 

 

 



 

  3 

 

1. Einleitung und Einstiegshilfen für ADS 2012 
Dieses Dokument soll einen schnellen Einstieg in die EDA-Software ADS 2012 von Agilent erleichtern und 

Hilfe zu Themen im Zusammenhang mit dem Studentenprojekt im Modul „Telecom-Elektronik“ anbieten. 

Bei Teilen die der englischen Benutzerführung in ADS naheliegen oder Auszüge aus ADS-Help beinhalten, 

wird die englische Sprache verwendet um die Terminologie beizubehalten. Andere Teile werden in deut-

scher Sprache beschrieben. 

 

ADS Help Documentation 

„Advanced Design System Quick Start”: adstour.pdf 

Dieses Dokument ist auf Boiler classes\ADS2012 abgelegt. 

 

ADS Homepage 

http://www.home.agilent.com/agilent/product.jspx?nid=-34346.0.00&cc=US&lc=eng 

 

Agilent EEsof EDA Forums 

http://www.home.agilent.com/owc_discussions/forum.jspa?forumID=104 

 

ADS 2012 Quick Start for New Users of ADS: 

(sehr zu empfehlen) 

http://wireless.agilent.com/flash/eesof/ADS_QuickStart_2012_for_NEWUSERS/player.html 

 

Agilent Kanal auf YouTube: 

http://www.youtube.com/user/AgilentEEsof 

ADS Overview: 

http://www.youtube.com/watch?v=i0IUAZ8GNyw&list=PLD918C8711CD75559&index=1 

 

Agilent Video Homepage: 

(Videos zu älteren ADS-Versionen) 

“The Basics of Advanced Design System”:  
http://wireless.agilent.com/vcentral/viewvideo.aspx?vid=338     

weitere Videos: 

http://wireless.agilent.com/vcentral/          suchen nach ADS oder Advanced Design 

 

Direkte Links aus dem ADS Welcome-Window: 
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2. The ABC of ADS 
A very short step by step Quickstart for first time users.  
This gives you a first feeling of this powerful software package, without claiming completeness or de-

tails. For more detailed information see Help documentation. 

After launching ADS and open or create a new workspace there are 3 main steps to get simulation 

results: 

A Draw schematic 
 
B Setup and run simulation 
 
C Display data from simulation 

 

2.1. Main Window 
 

After launching ADS 2012: 

 

 Startup Wizard: 

 

 
 

 Main window: 
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2.1.1. Opening an existing workspace: 

   File > Open > Workspace     or     

 

When the directory from which you launch the program contains workspaces, they are listed in 

the main window. Browse to the desired directory and choose workspace to open. 

 

 
 

2.1.2. Creating a new workspace: 

          File > New > Workspace     or      
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Names: 

Do not use dash (-), use underscore (_) instead. 

Do not use vowel mutation (Umlaut), use „ue“, „ae“, „oe“ instead. 

 

 
Never use spaces or dashes in any names. Use underscore instead. 

 
2.1.3. Copying a workspace: 
 
Use Window Explorer to copy workspaces. 

 

 
2.1.4. Covert a project from ADS 2009 or older to a workspace: 
 
          File > Convert Project to Workspace  
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2.2. Step A: Draw Schematic 
 
Creating a new schematic view 

In Main window:          File > New > Schematic     or      

 

 
Enter an appropriate name for the cell.  

 

Edit View Name to “schematic_ideal”. 

 

 
Click OK. 
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Click OK. 

 
Cancel the schematic wizard. 

An empty schematic named schematic_ideal opens and is ready to draw the schematic.  
 
Schematic Window 
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Toolbars can be customized by adding or deleting icons in menu “Tools > Hot Key/Toolbar Configu-

ration > Toolbar >Toolbar Groups”. 

 

 

Component 
palette

Currently selected 
action

Number of currently 
selected items

Current insertion 
layer

Cursor position 
related to 

center marker

Cursor 
position 

related to 
selected 
element

Schematic 
units

Center marker

Center marker

Component palette

 
 

 

 

Select desired component palette

Click to place component to schematic 
(Ctrl+R to rotate component)

Click to place ground to schematic

Click to place pin to schematic

Click to connect components with wires

double-click component to edit 
component parameters

Insert > Text (or Ctrl+Shift+T) to insert 
text in schematic. Do not use „Umlaute“. 
Double-click text to edit  properties.
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2.2.1. Component Parameters 
Hide/Display Parameter: Double-click component

  
 

Move component text: Edit > Text > Move Component Text, or F5 or right click on component 

 

 
2.2.2. Vendor Component Libraries  
Supplied with ADS 2012. To find in Installation-directory of ADS2012 \oalibs\componentLib. 

 

RF Passive SMT Library SMT Inductors, Capacitors, Resistors 

muRata Manufacturing Meas-

urement-Based SMT Library 

muRata SMT Inductors, Capacitors 

RF Transistor Library Packaged, BJTs, GaAsFETs, RF Power MOSFETs, nonlinear 

Microwave Transistor Library Chip BJTs, Chip GaAsFETs, Chip+Packaged HEMTs, nonlinear 

High-Frequency Diode Library Diodes, nonlinear 

Analog Parts Library Diodes, BJTs, MOSFETs, JFETs, no package, nonlinear 

S-Parameter Transistor Li-

brary 

Diodes, Transistors, no package, linear S-Par 

System Library Amplifiers, Filters, Cristals, Mixers, Switches, etc. 

 

Add a vendor component library to your workspace: 

Main window: DesignKits > Unzip Design Kit 

Browse to installation-directory of ADS2012 \oalibs\componentLib and select desired library. 
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Click Open. 

Directory to unzip file: Use directory “Libraries” in startup directory of ADS. If this directory does not exist, 

create it. 

Use proposed name for Design Kit. 

 
 

Check Libraries in Workspace: 

File > Manage Libraries > Add Design Kit from Favorites 

 
Close all. 
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The components are accessible in schematic window. Open the library browser , right click at de-

sired component to place component in schematic. 

 

 
 

 

 

2.3. Step B: Setting Up and Launching a Simulation 
 

 
Setting Up a Circuit Simulation  
 
A simulation is set up in a schematic win-

dow, using sources and simulators availa-

ble in the Palette List.  Simulator compo-

nents are placed in the Schematic win-

dow.  Simulation data are stored into a 

dataset.  
 
 

You could just add a simulation controller and terminations directly on this schematic and run a simulation. 

However, I think it is a better practice to instead treat this as a subcircuit that we place into a separate “test 

bench” schematic. This allows to use several test benches with different simulations on the same circuit. 

In order to do this, we must create a Symbol view. 
 
Creating a symbol view  
In the ADS Main Window, highlight the LP_Cheb cell and right click to select New Symbol. 
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The defaults in the New Symbol dialog are good, so just click OK. 
 

 
The defaults in the Symbol Generator are fine. Click OK. 
 

 
 
This is the default symbol that gets created. 

 
Edit the symbol to your choices or use one of the predefined symbols from ADS (see 5.4. Create New 

Symbol). 
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Now we have a design in a schematic and a symbol for it. Next, we will create a “test bench” to simulate its 

performance. 

 
Creating a library of test benches  
Assuming there may be many test benches, we will create a test bench library. From the ADS Main Win-

dow, select File > New > Library… 

 

 
 

Click Next >. Since we intend for this library to only contain schematics for simulations, we will select one 

of the standard ADS layers for the technology. 

 
 

Click Next > then Finish. 
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Creating a new schematic view to run a simulation  
Now we will create a cell within this new library. In the ADS Main Window select the schematic icon enter 
an appropriate name for the cell.  

 
Click OK, and a blank schematic and the schematic wizard opens. Cancel schematic wizard. 

From the ADS Main Window, you can just drag the symbol view from LP_Cheb-cell into this schematic.  

Place SP Simulation component and termination component to schematic. Set frequency sweep settings 

as desired.  

1. Select desired component palette

2. Click to place SP simulator component to schematic

3. Click to place 
termination to 
schematic

4. double-click component to edit component parameters

 
Alternatively to manual placing simulator and terminations you can use a template. From the schematic 

select Insert > Template… In the Insert Template dialog, highlight the S_Params template and click OK. 

Adjust the frequency sweep settings as desired. 
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Specifying the view to simulate  

Click on the LP_Cheb symbol to select it. Next click on the Choose View for Simulation icon . 

 

 
 
In the Choose View for Simulation dialog, click on Use this view for Simulation. 

 

 
 

Click OK. Note that schematic_ideal now appears under the LPF symbol in the schematic. 
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Launching the Simulation  
 
You can launch the simulation from the schematic window Simulate > Simulate, or from the Simulation 

Setup dialog box, or F7, or with   .   

 

The simulation runs quickly and opens a data display. Note that this data display file is not saved in your 

workspace unless you specifically save it. 

 

Note By default, all simulations in the schematic window are run. 

 

 
DC Bias Back Annotation 
 

lmmediately following a DC simulation: 

 

Simulate > DC Solution displays current and voltage data at the ports of active devices and lumped 

elements. 

 

Simulate > Detailed Device Operating Point displays a detailed listing of operating points for all 

parameters of a selected device. 

 

Simulate > Brief Device Operating Point displays a brief listing of operating points for common pa-

rameters of a selected device. 

 

Simulate > Clear DC Annotation removes the current and voltage text produced by DC Solution. 

 

 

2.4. Step C: Display Simulated Data 
 
Data Display Window 

 

End 
command, 
return to 

select mode

Open an 
existing 

Data 
display

Print 
current 
Data 

display

Delete 
items

Undo 

Zoom 
area

View all Zoom in by 2

Zoom out 
by 2

View 
actual size

Toggle 
activation of 

object

Redraw

Open a 
new Data 

display

Save current 
Data display

Redo

View 
previous 

page

View 
next 
page
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Zoom on Data

Autoscale 
Plot

Zoom in 
by 

rectangle

Zoom in

Zoom out

Data File 
Tool

Scroll Data 
in Lists

Default 
Dataset
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Doubleclick to Equation 

 

S11, S(11) and S(1,1) are 

equivalent 

Doubleclick to plot 

Plot options 
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3. ADS 2012 Design Environment 
 
Advanced Design System (ADS) 2012 provides a complete new design environment (see “Advanced De-
sign System Quick Start” adstour.pdf) and terminology for existing ADS users. ADS Projects are replaced 
with workspaces, designs are now Cells and Views. To use your existing ADS Projects and designs (cre-
ated using earlier versions of ADS) with ADS 2012, you must upgrade them to an ADS Workspace (see 
“ADS Quick Reference” oaqkref.pdf). 

 

ADS Workspace 
ADS 2012 uses workspaces to store and organize the design work. A Workspace is an organizer where 
you can group everything about a design within— such as libraries, technology, schematic, layout, simula-
tion data, and Momentum data. The entire ADS user interface and simulation operates within a currently 
opened workspace. 
 
A Workspace includes: 
Library: A Library is a directory that holds cells and a definition file, such as lib.defs. This file contains a 
summary of all the libraries selected into the given workspace and their mode of operation (Read-only, 
Non-Shared, or Shared). A Library also defines the technology (layers, resolution, and layout units) to be 
used by the Views created in that library.  
Cell: A cell is a sub-directory that contains zero or more views. 
. 
View: A View is a sub-directory in a cell that stores the design work such as 
schematic, symbol, or layout, and can store other related data, such as an EM Setup. 
 
Workspace Features 
The following are the key features of an ADS workspace: 

• Workspaces can have multiple libraries. Each Library can have multiple Cells, and each Cell can 
have multiple Views. 

• Workspaces can be archived or un-archived. 
• Workspaces contain data that includes simulation results, data display files, and other data files. 

 
In an ADS Workspace, 
1. A component name consists of the library name and cell name of the component. 
2. A design name consists of the library name, cell name, and view name of the design. 
3. Forms and Formsets are defined in a library. 
 
The following figure displays the hierarchy of an ADS Workspace: 
 

 
 
From the ADS Main window, the view options are provided for a workspace in three different tabs: “File 
View”, “Folder View” and “Library View”. 
These tabs show a different view of the workspace and the loaded libraries. Changes made in any of these 
tabs (such as renaming or deleting a file or view) will affect all three tabs. 
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File View: 

 
 
In the File View, you can: 

• Browse to other directories (similar to previous releases) 
• See the actual files that are stored in the file system 

 
Folder View: 

 
 
In the Folder View, you can: 

• Create virtual folders to group related files (similar to previous releases) 
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Library View: 

 
 
In the Library View, you can: 

• View the system organization of a workspace 
• Find files by type 

 
Library 
A Library is a subdirectory that includes cells. Libraries are used by specifying the subdirectory in a library 
definition file, such as lib.defs. This file defines name of the library and the mode of operation (Read Only, 
Non-Shared, or Shared). Files within the library itself define the technology (layers, resolution, and layout 
units) to be used by Views created in that library. 
All types of designs are contained in libraries. Design kits in ADS 2012 contain libraries with cells. User 
workspaces contain libraries. Native ADS components themselves are also contained in Libraries. 
The process information such as layer definitions, units, and substrates are defined in the technology of a 
library. You can create multiple libraries within a complete design hierarchy. Library usage is defined by a 
file lib.defs. A library may reside physically in the workspace directory. 
The following are the key features of a Library: 

• Each Library has a unique name and path, specified in a library definition file. (Note that the library 
itself does not specify its name. The name must be specified correctly in a lib.defs file.) 
Note 
Two libraries with the same name cannot be open at the same time. 
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• Associated with a Technology that defines physical layers, units, etc. The technology can be a na-
tive one created for a library, or it can be referenced to another library’s. 

• Contains zero (0) or more Cells. 
• Loaded/unloaded independently or collectively loaded through a lib.defs file. 
• Defines the technology (layers, resolution, layout units) that it will use. All views in a library uses 

the same technology. 
Cell 
A Cell is a container for Views. It is an equivalent of an ADS design (ADS 2009 Update 1 
and earlier releases), as it may contain schematics, layouts, and symbols. 
Each Cell: 

• Must have a unique name in the library, although cells with the same name may exist in another li-
brary. 

• Contains zero or more views. 
• May have multiple views of the same type. 
• May have a component definition, edited by choosing File > Design Parameters... while editing 

one of its views. 
View 
A View is a sub-directory in a cell that stores design information such as schematic, symbol, or layout. 
Views may also store an EM simulation setup or an EM Model. Each view is a container that stores a file or 
a database object. It is a specific representation of a cell. All views in a given library use the same technol-
ogy. 
Each view: 

• is associated with a Cell. 
• must have a unique name in the Cell. 
• Note 

Schematic, Layout, and Symbol Views should generally be named as schematic, layout, and sym-
bol unless you are using polymorphism. 

• Has a type (schematic, layout, symbol, EM Setup, EM Model). 
 
For more information see “Advanced Design System Quick Start” adstour.pdf, “ADS Quick Reference” 
oaqkref.pdf and product documentation. 
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4. Simulations in ADS 
Description Typical Use 
DC  

Fundamental to all RF/Analog simulations. It performs a topology check and 

an analysis of the DC operating point. 

All RF/Analog designs 

AC  

Obtains small-signal transfer parameters like voltage gain, current gain, and 

linear noise voltage and currents. 

Filter 

Amplifier 

S-Parameter  

Provides linear S-parameter, linear noise parameters, transimpedance, and 

transadmittance. Can be used to achieve many goals of the AC simulator. 

Filter 

Oscillator 

Amplifier 
Harmonic Balance  

Uses nonlinear harmonic-balance techniques to find the steady-state solution 

in the frequency domain. 

Mixer 

Oscillator 

Power amplifier 

Transceiver 
Circuit Envelope  

Uses a combination of frequency- and time-domain analysis techniques to 

yield a fast and complete analysis of complex signals such as digitally modu-

lated RF signals. 

Mixer 

Oscillator 

Power amplifier 

Transceiver 

Phase-locked loop 
LSSP  
Performs large-signal S-parameter analyses to represent nonlinear behavior. 
The accompanying P2D simulator can be used to speed up subsequent analy-
ses. 

Power amplifier 

Transient/Convolution  
Solves a nonlinear circuit entirely in the time domain using simplified models to 
account for the frequency-dependent behavior of distributed elements. 

Mixer 

Power amplifier 

Switching circuits 
Ptolemy 
Uses Digital Domain for simulation. 

Digital Circuits 

DSP 
Momentum 
Electro-magnetic Simulation of planar structures 

Layouts 

FEM 
Full 3D Finite-Element Electro-magnetic Simulation of 3-dimensional struc-
tures 

Filters, Antennas, Cou-

plers, Multilayer 
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5. Working with Symbols in ADS2012 
(Hierarchical Designs, Subnetwork, Subcircuit) 

 

To explain working with symbols in hierarchical designs, we use a step-by-step example with a workspace 

Symboltest_wrk. The archived workspace is available as Symboltest_wrk.7zap. 

Circuits (or Subcircuits) with their symbols are organized in a Library Circuits_lib. For each circuit we use 

a cell containing a schematic and its symbol. 

Simulations are organized in a Library TestBenches_lib. For each simulation we use a cell containing a 

schematic with simulation-circuit. 

In this step-by-step example we use schematics and symbols for a LC-lowpass filter and a LC-highpass 

filter in the library Circuits_lib. In the library TestBenches_lib we have schematics with S-parameter sim-

ulation for each filter and for cascaded filters. 

 

Schematics and symbols 
for the filters

Schematics for simulations

Data Display files

Dataset files
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Example: 

 
 

5.1. Create New Workspace 
From the ADS Main Window, choose File > New > Workspace. Name the library Circuits_lib. 

 

 
 

5.2. Create New Library 
From the ADS Main Window, choose File > New > Library. Name the library TestBenches_lib. 

 

 
 

5.3. Create New Schematic 

From the ADS Main Window, choose File > New > Schematic or click  and create the new schematic 

in library Circuits_lib. 

Name the cell LP_Filt and accept the schematic default name schematic. 

Insert components and complete schematic as shown below. 

Save schematic . 
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5.4. Create New Symbol 

From the ADS Main Window, choose File > New > Symbol  or click  and create the new symbol in 

library Circuits_lib. 

Browse Cells and select LP_Filt and accept the symbol default name symbol. 

 
 

Symbol Type Description 

Dual Restricts pins to two sides of sym-

bol body 

Quad Allows pins on all four sides of 

symbol body 

Order Pins by Description 

Location Numbers pins in the same relative 

order as the ports on the schematic 

Number Numbers pins sequentially in a left-

right, top-down order 

Lead Length and 

Distance Between 

Pins 

Be careful altering this values. The 

values have to fit the grid spacing 

in schematic. 
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The generated default symbol can be edited as desired at any time. 

Add text, change shape of symbol as desired. 

Be careful moving pins. They have to fit the grid spacing in schematic. 

See help “Working with Symbols”. 

 

 
 

Alternatively one of the many symbols from ADS can be used: 

 

 

 

 

 

 

 

Use this to select one of the many symbols from 

symbol library. 
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5.5. Setting Design Parameter 
To pass component parameters from schematic to symbol view they have to be set in schematic. To define 

the parameters that should be passed to the upper-level symbol: 

Open the schematic in the cell LP_Filt  

Choose File > Design Parameters. In the Design Parameters dialog box, select Cell Parameters tab 

and enter variables and default values for the capacitor and inductor. 

 

 

 
 

Click OK to close this dialog box, save and close the schematic. 

 

5.6. Using Symbol in Other Schematics 
The symbol can be used in any other schematic. The parameter we assigned (capacitance and inductance 

in this example) will pass through to the network. 

In this example we create a schematic in the TestBenches_lib with the cell name TestBench_LP_Spar to 

perform a S-parameter simulation on the lowpass filter. 

From the ADS Main Window, choose File > New > Schematic or click  and create the new 

schematic in library TestBenches_lib. Name the cell TestBench_LP_Spar and accept the schematic 

default name schematic. 
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Insert the symbol by simply drag it from the Main window, Folder View or Library View to the schematic 

TestBench_LP_Spar. 

 

 
Complete schematic with S-parameter simulation template: Insert > Templates > S_Params and set 

frequencies to desired values. 

Save schematic . 

 

Specifying the View to Simulate 

In the TestBench_LP_Spar schematic, select the LP_Filt symbol.  
 

 

Click Choose View for Simulation icon.  
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In the Choose View for Simulation dialog box, select Use this view for Simulation.  
 

 

Click OK. Note that schematic now appears under the LPF symbol in the schematic.  
 

 

 

Modifying the schematic of a symbol 

If you make changes in the schematic  that affect the component definition (any changes in the Design 

Parameters dialog box-information), that serves as a subnetwork in a higher-level design, you need to 

explicitly update the symbol to recognize those changes. 

To update a symbol that contains a modified subnetwork: 

Select the symbol and choose Edit > Component > Update Component Definitions.  

Select the option Update Component Definitions in Subnetwork and click OK. Changes to any 

subnetwork designs are now reflected in the symbol.  

 

Viewing the Network Represented by a Symbol 

Whenever your design contains a symbol that represents a network, you can view the actual network 

being represented by the symbol by using the Push Into Hierarchy command.  

To push into and then pop out of an item: 
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Select the item.  

Choose View > Push Into Hierarchy or . The network represented by the symbol is displayed. 

 

 
 

 
 

The Pop Out of Hierarchy   command is the reverse of pushing, and only works if a design has 

been pushed into.  

When you are through viewing the network, choose Pop Out of Hierarchy and you are brought back to 

the item (or schematic containing the item).  
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5.7. Now everything is ready for simulation. 
 

 
 

Start simulation  and display simulation results. 
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6. ADS   Optimization Cockpit 
For usage of Optimization Cockpit see: 

http://www.youtube.com/user/AgilentEEsof#p/c/FF7051B3E314AD45/41/m0UkqaqVDoQ 

 

 

 
 

If you are missing icons in the toolbar you can customize your toolbar (add or delete icons): 

Menu: Tools -> Hot Key/Toolbar Configuration 

 

 



 

  37 

 

6.1. Setup for Optimization 
• Place an Optimization-item and Goals to the schematic. 

Optim
Optim1

EnableCockpit=yes

SaveCurrentEF=no
UseAllGoals=yes
UseAllOptVars=yes
SaveAllIterations=no
SaveNominal=no
UpdateDataset=yes
SaveOptimVars=no
SaveGoals=yes
SaveSolns=yes
SetBestValues=yes
NormalizeGoals=no
FinalAnalysis="None"
DesiredError=0.0
MaxIters=100
OptimType=Gradient

OPTIM

Goal
OptimGoal1

Indep1Max[1]=1 GHz
Indep1Min[1]=10 MHz
LimitWeight[1]=1
LimitMax[1]=-19.4
LimitMin[1]=
LimitType[1]="LessThan"
LimitName[1]="Limit1"
IndepVar[1]="freq"
Weight=1
SimInstanceName="SP1"
Expr="dB(S11)"

GOAL

Goal
OptimGoal3

Indep1Max[1]=3 GHz
Indep1Min[1]=2 GHz
LimitWeight[1]=10
LimitMax[1]=-25
LimitMin[1]=
LimitType[1]="LessThan"
LimitName[1]="Limit1"
IndepVar[1]="freq"
Weight=1
SimInstanceName="SP1"
Expr="dB(S21)"

GOAL

Goal
OptimGoal2

Indep1Max[1]=4 GHz
Indep1Min[1]=1 GHz
LimitWeight[1]=1
LimitMax[1]=
LimitMin[1]=-19.4
LimitType[1]="GreaterThan"
LimitName[1]="Limit1"
IndepVar[1]="freq"
Weight=1
SimInstanceName="SP1"
Expr="dB(S11)"

GOAL

 
 

• Setup Variables or element values for Optimization 

VAR
VAR1

L3=18.5051 {o}
L2=13.1403 {o}
L1=10.6206 {o}

Eqn
Var
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Optimization 

 

The Optimization Cockpit is a live, graphical view of an optimization job. You see the cockpit data (error 

graphs, goal plots, and variable values) change in real time as the optimization progresses. In addition, you 

can use the cockpit to control the optimization while the optimization is running. For example, during the 

course of an optimization, you can increase the range of an optimization variable, modify the limit line of a 

goal, tune the optimization variables, and change the algorithm from Random to Gradient. 

Cockpit Panels 

The cockpit has three main panels: Status, Variables, and Goals. It also has a control panel on the left-
hand side. 

 

Status panel 

The Status panel displays the optimizer's status, type, elapsed time, and progress. It also has a button for 
changing the optimization algorithm settings. 

 

Activities 

Roll the pointer over the status icon to know the state of the optimizer 

 

While the optimizer is paused or towards the end of an optimization, click Edit Algorithm to modify the 
optimization algorithm. See “Modifying the algorithm” for more information.  

Variables panel 

The Variables panel displays the optimization variables as a row of sliders and as data in tabular format. It 
also has buttons for tuning and for editing the variable definitions. 
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The sliders represent the current value of each optimization variable relative to its minimum and maximum 
values.  

Each row of the table shows important information for each optimization variable:  

• Name  

• Current value  

• Units (if any)  

• A history graph showing the values of the variable over the course of the optimization.  

 

Activities 

Click a row in the table to highlight its corresponding slider or vice-versa 
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Move the pointer over a slider to see information about that variable 

 

Click Start Tuning to switch to tune mode. See “Tuning” for more information.  

While the optimizer is paused or towards the end of an optimization, click Edit Variables to modify the 
variable settings. See “Modifying variables” for more information.  

 

Goals panel 

The Goals panel displays the current error, the error history graph, the goal contribution histogram, and the 
goals table. It also has a button for editing the goal definitions. 

 

The Error history graph shows the overall error over the span of optimization. 

 

The Goal contributions histogram is displayed when there are two or more goals. It represents each goal's 
contribution to the overall error. 

 

The table contains a row for each goal. Each row represents the following information:  
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• A plot of the goal's response and limit lines. The limit lines are red and the response is blue. 

 
The solid blue trace is the response for the current values of the optimization variables. The 
dashed blue trace is the response at the beginning of the optimization.  

• A history plot of the goal's error over the span of optimization. 

 
 

 

Sometimes you will notice the error for a goal increases. The optimizer is driving the overall error to 

zero, so the error for a particular goal can increase as long as the overall error decreases. 

A Contributions histogram is displayed only when the goal has more than one limit line. The histogram 
shows each limit line's contribution to the goal's error. 

 

 

Activities 

Move the pointer over the Error history graph to see information about the error:  

 

Move the pointer over a bar in the Goal contributions histogram to see information about that goal's 
contribution to the error: 
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Click a bar in the Goal Contributions histogram to highlight the corresponding goal in the table or click a 
goal in the table to highlight the corresponding bar in the histogram: 

 

Move the pointer over a bar in the Contributions histogram to display the contribution percent and to 
highlight the corresponding limit line on the plot: 

 

Move the pointer over a limit line to see information about that limit line: 

 

Move the pointer over a data point in the trace to see the coordinates of the point: 

 

While the optimizer is paused or towards the end of an optimization, click Edit Goals to modify the goal 
settings. See “Modifying goals” for more information.  
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Stale plots 

Goal plots go stale when the algorithm, goal, or variable settings change, but no simulation is performed. 

 

This means that the simulation results (error value, the contribution graphs, and the goal plots) displayed in 
the Cockpit do not accurately reflect the current algorithm, goal, and variable settings. For example, click 
Edit Goals and modify one of the limit lines you will see the goals plot will go stale. Click Simulate to 
refresh the goals plot. 

Control panel 

This panel has several buttons on the left-hand side of the Cockpit that helps you to control the 
optimization while it is running. 

Pause 

Click Pause to pause a simulation while it is running. Once an optimization is paused, you can interact with 
the optimizer. It can take time for the optimizer to pause when the low-level simulation (for example, 
transient or harmonic balance) takes a while to run. 
The Pause button changes to Continue when an optimization is paused or is completed. 

Continue 

Click Continue to continue the optimization. This button is available when the optimizer is paused or has 
finished. 

 

If the optimizer has reached the maximum number of iterations and you click Continue, you can in-

crease the maximum number of iterations. 

Simulate 

Click Simulate to re-evaluate the goals. This is useful after you have changed the settings (for example, 
modified a limit line on a goal) and you want to update the goals plots or see the new error value.  
It is also useful in Simulate after pressing Simulate tuning mode. See “Tuning modes” for more 
information. 

 

Data Display graphs do not get refreshed on clicking Simulate.

Update Design 

Click Update Design to transfer variable values to the design.  
This command can also transfer algorithm and goal data to the design. This is useful when you have used 
Edit Algorithm or Edit Goal to modify the algorithm or goal definitions. For more information on modifying 
the goal or algorithm settings, see “Controlling the Optimization”. 

Note: The options you specify while updating the design do not change from one optimization to other. 

If the sweep panel is displayed (see “Sweep Panel”) when you click Update Design, the design is updated 
using the optimization specified by View. 

Store 

This option allows you to store the current optimization state. For more information, see “Using 
Optimization states”. 

Recall 

This option helps you to recall a state. For more information, see “Using Optimization states”. 
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Options 

It allows you to view the Cockpit options. For more information, see “Scaling the plots”. 

Close 

Click Close to close the Optimization Cockpit. If the optimization is still running, you have the option to stop 
it or to update the design. 

Controlling the Optimization 

Modifying the algorithm 

Follow the steps below to modify the algorithm: 

1. Click Edit Algorithm.  

2. Change the optimization type or the maximum number of iterations. 

 

3. Click OK. 
Note: When you click OK, the Optimization component on the schematic is not updated.  

4. Click Update Design to transfer the new settings to the schematic.  

Modifying goals 

Follow the steps below to modify the goals definition: 

1. Click Edit Goals to view or modify the goal definitions. 

 

2. Goals are listed in the Goals list. Click an entry from the list to view its properties. You can change 
the goal's weight and also the definition of each limit line. From the cockpit, you cannot change a 
goal's name, expression, or analysis. Also, it doesn't allows you to add a new goal, delete an 
existing goal, or change the name of a limit line.  

 

Set Weight = 0 to disable a goal or a limit line.



 

  45 

 

3. After changing the goals definition, Click OK. 
Note: When you click OK, the Goal components on the schematic are not changed.  

4. Click Update Design to transfer the new settings to the schematic.  

Modifying variables 

Follow the steps below to modify the variable settings: 

1. Click Edit Variables to view or modify the optimization variable settings. 

 

2. Select the check-box to enable that variable. 
The edit variable dialog box allows you to change the nominal value, format, and format's min and 
max values. It doesn't allows you to change a variable's name, add a new variable, or delete an 
existing variable.  

3. After modifying the variable settings, Click OK. 
Note: When you click OK, the variables on the schematic are not changed.  

4. Click Update Design to transfer the new settings to the schematic.  

Note: Variables of +/- Delta or +/- Delta% Format are handled differently. For these variables, the 
minimum and maximum values for the variable are calculated as offsets from the nominal value. This 
calculation is performed at the beginning of the optimization and the minimum and maximum values do not 
change as the optimization progresses. In the above example, it seems as if Delay is defined as 3.99544 
ns +/- 5%. This is not the case. At the beginning of the optimization, the nominal value for Delay was 4 ns, 
so the definition is actually 4 ns +/- 5%. When you edit any field for this variable and click OK or Apply, the 
variable's minimum and maximum are recalculated based on the value in the table; otherwise, the 
variable's minimum and maximum are not recalculated. 

Using Optimization states 

The cockpit has the ability to store and recall optimization states. This is useful when you explore the 
behavior of your design using the Optimization Cockpit. For example, before modifying some variable 
definitions or goal definitions, you can store the current optimization state and recall the saved state when 
required. 
The optimization state contains the algorithm, goal, and variable settings. 
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Store 

Follow the steps below to store an optimization state: 

1. Click Store 

 

2. Specify the name of a state in State name field  

3. Add a comment in the Comment field (optional)  

4. Click OK to store the current optimization state  

 

The Optimization Cockpit automatically stores the initial state.

Recall 

Follow the steps below to recall an optimization state: 

1. Click Recall  

2. Click a column heading to sort the states by that column 

 

3. Select a state  

4. Click OK or Apply to restore the selected state  

When you recall a state, the cockpit's algorithm, goal, and variable settings are replaced with those of the 
recalled state. It is similar to manually reverting back to previous settings using Edit Algorithm, Edit Goals, 
and Edit Variables to restore the state. This means that the history graphs and goal graphs do not change 
to what they were when you saved the state.  

When you recall a state the goal plots will go stale (see “Stale plots”). Click Simulate to recalculate the 
error and update the goal graphs. 

 

The automatically stored initial state has no Error value associated with it because the state is stored 

before any simulation is performed. 

Note: Optimization states are discarded when the Optimization Cockpit is closed. If you want to use an 
optimization state in your next optimization, click Recall to recall the state and then click Update Design to 
update the schematic. 
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Scaling the plots 

Click Options to view or modify the Cockpit options. 

 

History graph X-axis options These options modify the X-axis scaling of all history graphs (both error 
and variable history graphs).  

• Display the last 10 iterations The graph displays only the 10 most recent iterations.  

• Display the last 25 iterations The graph displays only the 25 most recent iterations.  

• Display all iterations Scales the X-axis from 0 to Max. iterations.  

History graph Y-axis options These options modify the Y-axis scaling of the error history graphs.  

• Auto-scale using visible data Consider only the iterations that are visible in the graph when 
scaling the Y-axis.  

• Auto-scale using all data If there are iterations that are not visible on the graph (for instance, the 
graph shows the last 10 iterations, but the current iteration is greater than 10) then consider the 
invisible iterations when scaling the Y-axis.  

Goal plots These options modify the X-axis scaling of all the goal plots.  

• Fit to trace Set the X-axis scaling to show the entire trace.  

• Fit to limit lines Set the X-axis scaling to show all the limit lines.  

• Fit to trace and limit lines Set the X-axis scaling to show all the limit lines and the entire trace.  

Note: All of these options are remembered from one optimization to the next. 

Tuning 

Click Start Tuning to start tuning. If the optimization is running, it will pause. 

While tuning, the Start Tuning button is renamed as Stop Tuning. 
To disable the tune mode: 

• Click Stop Tuning, or  

• Click Continue to resume the optimization.  
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You can modify the optimization variable values using the sliders or by entering values directly in the 
variables table.  

Note: The minimum and maximum values of the variables are determined by the optimization variable 
definitions. The settings used by the standard tune mode are not used. To change the minimum and 
maximum values for a variable, click Edit Variables. 

 

Data Display windows do not update while tuning.

Activities 

• Click a row in the variables table to highlight the corresponding slider. Click a slider to highlight the 
corresponding row.  

• On the keyboard, press Tab (or Enter) to move down in the variable table. Press Shift+Tab (or 
Shift+Enter) to move up.  

Tuning menu 

The Start Tuning (or Stop Tuning) button has a menu attached to it. Click the arrow to the right of the 
button to access the menu. 

 

Reset values 

Choose Reset Values to reset the optimization variable values to the values they had when you started 
tuning. 

Use the Store and Recall buttons to store and recall intermediate tuning states. For more information, see 
“Using Optimization states”. 

Tuning modes 

Tuning has three different modes. Use the Tuning menu to change modes. 

• Simulate while slider moves - In this mode, the simulator performs simulations while you are 
moving the slider. This is useful for faster simulations (less than 0.5s).  

• Simulate after each change - In this mode, the simulator waits to perform a simulation until you 
release the slider. This is useful when the simulations are not as quick (0.5s to 5s).  

• Simulate after pressing Simulate - In this mode, no simulations are performed until you click 
Simulate. This mode is useful when the simulation takes longer (greater than 5s) or you know in 
advance that you want to make several changes before simulating.  

Note: This setting is remembered from one optimization to the next. 

View-only mode 

The Cockpit switches to view-only mode when either of the following is true: 

• The top-level simulation controller is not an optimization. For example, there is a ParamSweep 
sweeping an optimization.  

• There are two or more top-level simulation controllers. For example, there is a top-level harmonic 
balance controller and a top-level optimization.  

In view-only mode, the cockpit still displays the real-time optimization data, but none of the interactive 
features is available. 
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Sweep Panel 

The sweep panel appears when there is more than one optimization in the simulation job. This happens 
when an optimization is swept (using a ParamSweep component) or when there is more than one 
optimization in the simulation job. 

 

Use the View drop-down list to select an optimization to be displayed by the cockpit.  

 

Changing the view has no affect on the simulation, so you can view the results of the first point in the 
sweep while the rest of the sweep is running.  
When you click Update Design, the design is updated using the optimization specified by View. 

A red icon in the View list indicates that the optimization was terminated because of a simulation error. A 
green icon indicates that no simulation error occurred. 

 

The green icon does not indicate that the error value for that optimization is zero. The error will be non-

zero if the optimization was terminated for other reasons (for example, maximum iteration limit reached, 

gradient is zero).  

Turning off the Optimization Cockpit 

You can turn off the Optimization Cockpit by clearing the Enable Optimization Cockpit checkbox on the 
Parameters tab of the Optimization component. 
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7. Default Keyboard Shortcuts (hotkeys) 
To customize the Keyboard/Toolbar, use the Main window command  

Tools > HotKey/Toolbar Configuration 

 

New Design Ctrl+N  Insert Wire Ctrl+W 

Open Design Ctrl+0  Insert Text Ctrl+Shift+T 

Save Design Ctrl+S  Insert Polygon Ctri+shift+P 

Print Design Ctrl+P  Insert Rectangle Ctrl+Shift+R 

Close Window Ctrl+F4  Undo Vertex Shift+Z 

   Snap Enabled (toggle) Ctrl+E 

Edit Undo Ctrl+Z    

End Command ESC  Window Schematic Ctrl+Shift+S 

Cut Ctrl+X  Window Layout Ctrl+Shift+L 

Copy Ctrl+C    

Paste  Ctrl+V  Simulate F7 

Delete Del    

Rotate Ctrl+R  Help Whats this Shift+F1 

Mirror About X Shift+X  Help Topics and Index F1 

Mirror About Y Shift+Y    

Move Ctrl+M    

Move Component Text F5    

     

Select all Ctrl+A    

View All Ctrl+F    

Restore Last View Ctrl+L    

Zoom In X2 Add (+)    

Zoom Out X2 Sub (-)    

Clear Highlighting F8    

Grid Display Ctrl+G    
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8. Built-in Constants, System Units and Prefixes 
 

8.1. Built-in Constants 
 

The following constants can be used in expressions: 

Constant Description Value 

PI (also pi)  3.1415926535898 

e Euler’s constant 2.718281822 

ln10 Natural log of 10 2.302585093 

boltzman Boltzman’s constant 1.380658e-23 J/deg.K 

qelectron Electron charge 1.60217733e-19 C 

plank Plank’s constant 6.6260755e-34 J-sec 

c0 Speed of light in free space 2.99792e+8 m/sec 

e0 Permittivity of free space 8.85419e-12 F/m 

u0 Permeability of free space 12.5664e-7 H/m 

i,j Sqrt(-1) 1j 

 

8.2. System Units 
 

Type Units 

Angle Deg 

Capacitance F 

Concuctance Sie 

Current A 

Frequency Hz 

Inductance H 

Length m, inch, mil 

Linear Power W 

Power (dBm) dBm 

Resistance Ohm 

Time sec 

Voltage V 

 

8.3. System Prefixes 
 

Factor Meaning System Prefix 

10e12 Tera t  or  T 

10e9 Giga g  or  G 

10e6 Mega  1) M (only) 

10e3 Kilo k  or  K 

10e-2 Centi c  or  C 

10e-3 Milli  1) m (only) 

10e-6 Micro u  or  U 

10e-9 Nano n  or  N 

10e-12 Pico p  or  P 

10e-15 Femto  1) f  or  F 

1) The prefixes m, M and f (or F) must be followed by a unit description (MHz, fF, mOhm, MOhm) or 

they will be ignored. 


